USB Mouse/Keyboard

Nov 24, 2009 at 5:34 AM

Hi all,

I've got CE 6.0 R3 booting successfully, with video out on the HDMI connector. The screen that comes up is the touchscreen calibration screen (click on the crosshair).

I've plugged a USB mouse and keyboard in through a powered USB hub, but neither seems to enumerate, so I can't dismiss the calibration screen. Any ideas?

(I've booted in Angstrom Linux, and they work fine there, so it's not a hardware issue).

Regards,

Mike

Nov 24, 2009 at 6:53 AM

Do mouse and keyboard work fine with same hub using Linux?  If so then you have a High Speed hub, and issue could either be SYSGEN/BSP variable config, or code changes are required to support host mode.  My effort has been on B7 hardware to date.  A C3 may be coming soon.

Your touchscreen driver is loading and looking in registry for calibration data, if it's not there it will propmt to calibrate.  

If you don't have a touch screen, then comment out the driver in platform.reg.  This would prevent it from loading.  Start commenting here:  [HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\TOUCH]

If you do want the touch screen driver,but don't want to be prompted for calibration then use "set IMGNOCALIBRATION=1".  This will cause the following to be included in the registry:

        [HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\TOUCH]

            "CalibrationData"="2016,1888 1056,864 992,2912 3040,2976 3072,896"

Nov 24, 2009 at 7:02 AM

Yes the mouse and keyboard work with the same hub using Linux.

I've managed to remove the touchscreen and backlight drivers so that CE boots to a standard desktop - but I still have no mouse or keyboard.

Even trying the sample images that are shipped with the BSP gives the same result. The hub has a light for each port that comes on when the device is enumerated - and there is no light under CE (but there is under Linux).

So, the touchscreen part of my question is not relevant any more - but I still have no mouse/kb.

You said "... issue could either be SYSGEN/BSP variable config, or code changes are required to support host mode".

Any clues as to which variables would be likely candidates for experimentation? And, do you have the KB/Mouse working on a B7 rev board, or is the problem across all revs of Beagleboard?

Thanks for your help,

Mike

Nov 24, 2009 at 7:14 AM

On the B7 the host connector isn't populated, so OTG only.  I haven't checked out OTG yet, as I need to pick up the special cable.

Are you connected to hub using OTG or Host connector?

 

From what I've gathered between the schematics it's not a one-to-one mapping for USB host:

OMAP Ball No. Built-in Function I/O EVM NET I/O Beagle B7 NET
AH14 ETK_D7/GPIO_21
HSUSB2_RESET

AF9 ETK_D8/GPIO_22
HSUSB2_VBUS_EN

AG9 ETK_D9/GPIO_23
USB2_HOST_FAULT

U3 GPMC_nBE1/GPIO_61
nUSB2_EN_1V8

N8 GPMC_nCS7/GPIO_58
HSUSB_OTG_FAULT

TPS65950 Ball No. Built-in Function I/O EVM NET I/O Beagle NET
N12 GPIO_1
HS_DET O HOST_nOC

 

Nov 24, 2009 at 7:20 AM

The hub is on the Host connector.

I'll keep playing. If you have any brainwaves, please let me know...

 

Thanks,

Mike

Nov 24, 2009 at 4:03 PM

Aha - solved!!

Putting the hub on the OTG connector (via a special OTG cable) did the trick. Would be nice to be able to use the Host connector, but the knowledge of what to change is beyond me right now.

I also set the environment variables bsp_usbotg = 1 and bsp_wce = 1, but I haven't tested to see if they were really necessary.

Regards,

Mike

Dec 2, 2009 at 6:47 AM

Good to hear OTG works as expected.

Yeah in my above spreadsheet snippet none of the host signals map directly to the code written for the EVM board.

I just checked in my GPIO spreadsheet.  I am hoping Pavel will confirm the net names and GPIO used for C2/C3 host mode.

Cheers,

Joel

Dec 3, 2009 at 2:01 AM

You may have already learned this but there are some I/O changes from Rev B to C boards.

It is possible to auto detect the board rev and therefore the I/O mapping dynamically at run time. The changes ripple through the Xloader platform file etc.

I have the HS-USB host also working with my BSP ... good luck .. it was a challenge. 

 

DV

Dec 3, 2009 at 2:16 AM

Hi DV,

> I have the HS-USB host also working with my BSP ... good luck .. it was a challenge.

Is that the BSP at http://beagleboard.codeplex.com?

If so I notice that it hasn't been updated since March, but you've obviously done some work on it since then. Any chance of an update?

I'm interested in the vision for that BSP - it seems that the TI one is encumbered by licence restrictions so the http://beagleboard.codeplex.com one would be the way to go moving forward. But I'm guessing there's a lack of people qualified (or interested ?) to move it forward, which is a shame.

Any thoughts on the future of the http://beagleboard.codeplex.com BSP?

 

Regards,

Mike

 

Dec 4, 2009 at 5:55 AM

Hi Mike,

I suggest you contact the person that started the beagleboard.codeplex project for an explanation.  He certainly has one.

Joel

Dec 5, 2009 at 7:02 AM

Hmm, I feel like I've stepped into some history/politics here...

So, Bill Mar is the originator of the project, but dvescovi seems to have done all the maintenance - I'm guessing your suggestion is to contact Bill Mar, but I don't want to put my foot in it if there is some bad blood there.

I also notice that dvescovi seems to be particularly active in the Gumstix BSPs, and I guess I wondered (perhaps naively) why there wasn't a similar community around the Beagleboard. It seems a shame whatever the reason.

I'm happy to play the role of the dumb beginner here and take whatever flack this question brings out, but I would still be interested to hear any discussion around the future of this BSP from Bill, dvescovi, Joel etc.

Maybe this belongs in a new thread though?

Regards,

Mike

Dec 5, 2009 at 7:36 AM

OK - I've started a new thread over on http://beagleboard.codeplex.com/Thread/View.aspx?ThreadId=77192 for any discussion around this question...

Jan 5, 2010 at 8:34 AM

Hi dvescovi
As per ur post here it seems u have been able to work with HS-USB port. Would you kindly help me with the changes u have done to make it work.
regards
parsh

Oct 12, 2010 at 9:36 AM
Edited Oct 12, 2010 at 9:46 AM
Mike said:

I've managed to remove the touchscreen and backlight drivers so that CE boots to a standard desktop - but I still have no mouse or keyboard.

Hello Mike,

since I got the same problems, I would enjoy if you could tell me how you manage to solve this first problem.

Then, I saew that concerning the mouse/keyboard issue, you solved it by plugging your hub to OTG. Since the post is old enough, I was wondering if since then you managed to connect the hub to USB Host ad make it work.

I don't know if you will ever see this post, I hope so...

thanks anyway,

Nathaniel

Oct 12, 2010 at 11:36 AM
Hi Nathaniel,
It’s been a while – you are right Smile
I was using the standard “USB Host” port when I had the problem. What I ended up doing was getting a special USB OTG cable – like this one http://www.amazon.co.uk/OTG-Cable-Adapter-plug-Socket/dp/B000EORX7U and using the small “USB OTG” port.
I hope this helps,
Mike
From: [email removed]
Sent: Tuesday, October 12, 2010 7:37 PM
To: [email removed]
Subject: Re: USB Mouse/Keyboard [evmonbeagle:76043]

From: nathasion

Hello Mike,

Since I am encoutering same problems (CE booting on calibration screen, and no mouse), may I ask you how did you solve them?

I see the post is old enough and maybe you may have some new solutions to propose, as I am exactly starting at trying to adapt the TI_EVM on my BB,

Thak you for your help,

Nathaniel

Oct 12, 2010 at 2:09 PM

Hi Mike

thanks for answering.

as a matter of fact, I was expecting you found a solution to use the Host USB port since the OTG is needed most of the time and I don't want to start changing the plugs all the time. Moreover, I really want to understand ohw to make everything work.

Anyway, thank you for having answered.

Nathaniel