EBVBeagle rev.C2

Nov 30, 2009 at 4:56 PM
Edited Nov 30, 2009 at 5:02 PM


I'd like to share my experience in adaptation/portation of Windows CE BSP for OMAP35x Processors to EBVBeagle rev.C2

* Abstract
First of all I'm not going to provide any source code here, because of two reasons:
1. I respect rights of BSP developer - Bsquare/Texas;
2. In my opinion the principle is more valuable than just piece of code.
It assumes that reader is familiar with Windows Embedded CE 6.0 toolkit and terms like "flat release directory" and "KITL" are clear.
So 2 weeks ago I've got EBVBeagle rev. C2 (http://www.ebv.com/en/products/categories/details/type/categories/category/dsp-mpu/product/ebvbeagle-board.html?ct_ref=u162&cHash=890a8000cc). Formerly I heard about this interesting product which combines powerful hardware and ultra compact size. Now I am working on demonstration device which should support user interaction. So tasks are as follows:
1. Bootloader
2. KITL connection for debugging purposes
3. User input from USB mouse/keyboard using onboard USB HS host controller.
4. Output to standard display with DVI-D

* Development toolchain
Besides Windows Embedded CE 6.0 toolchain (VS2005+SP1 & Windows CE 6.0 Platform Buider+SP1+R2+R3) also OMAP35xx BSP (http://focus.ti.com/docs/toolsw/folders/print/dvsdk-winceomap.html) should be installed. Please read "License Argeement" provided with BSP installer carefully. I started with BSP v.6.09 and migrated to v.6.12. In new version of BSP common platform code was moved to PLATFORM\COMMON folder. It's a typical approach to divide platform specific and common SOC code.

* Bootloader
In my case no any additional efforts are required to boot up board. So I'll just put here main topics from BSP documentation. There are two options for bootloader location: onboard NAND or SD card. By default NAND is used. To boot from SD USER button should be pressed and then RESET button. Also bootloader and/or runtime image should be placed on NAND/SD. Here is procedure for SD preparation:
1. Mark partition on SD as bootable. I did it by diskpart utility of Windows 7.
2. Format partition. Exactly format not just delete its content. That because bootloader have to be at very beginning of partition
3. Copy MLO, first part of bootloader, to SD.
4. Copy EBOOTSD.nb0 and other required files.
Bootloader binaries are provided with BSP package in Images folder or you can use binaries which will be placed to flat release directory after building of runtime image. To update MLO steps 2-4 should be repeated. After bootloader has booted up it should be properly configured through serial port using programs like HyperTerminal or Putty. Unfortunetly current version of bootloader for SD doesn't support saving of settings.

* Connectivity
BSP provides connectivity of device with development station for download and debugging purposes and fortunetly it works on this board without any extra undocumented actions. Because of lack of Ethernet controller the only option here is USB RNDIS. USB RNDIS is provided by USB OTG controller (mini AB-type connector). When USB RNDIS is used as KITL transport all USB drivers for this controller are disabled. To recognize connected device as USB RNDIS driver should be installed on development station. Actually Inf-file with appropriate hardware IDs is required only, because of binaries come with Windows OS. To successfully accomplish following steps prepare bootable SD card as mention earlier, connect mini-USB port (USB OTG) and serial port header (RS232) to development station and run terminal program (HyperTerminal/Putty).
1. Create RNDIS Inf-file using template from MSDN article (http://msdn.microsoft.com/en-us/library/bb500930.aspx)
2. Boot up device, wait for "Hit space to enter configuration menu" message in terminal program window and press <Space> key.
3. Configure bootloader to boot from USB RNDIS (press <2> key twice) and press <0> to initiate boot process.
4. New device should be detected on development station.
5. Go to Device Manager and determine hardware Id. In my case it is "USB\VID_045E&PID_0301"
6. Replace hardware Id in Inf-file and save it.
7. Update driver using produced Inf-file.
Then network infrastructure should be configured. Generally there are two options: static IP addresses or DHCP server. To speed up boot process I use static IP addresses. So setup IP for RNDIS connection on development station (for example and on device using bootloader configuration menu (for example Now Platform Builder should recognize the device. To use KITL connection USB RNDIS has to be chosen as "KITL (Debug) Device" in bootloader configuration menu.

* USB HS host
Starting from revision C2 BeagleBoard supports two USB hosts: USB OTG with mini AB-type connector and USB HS Host with regular A-type connector. BSP provides drivers for both controllers but unfortunetly none of them works out-of-box for me. As USB OTG can be exclusively occupied by KITL transport get working USB HS host is more preferable task. In Windows CE USB host drivers has "layered" architecture, that is driver consists of several parts: PDD - platform dependent and MDD - model, platform indepenedent. MDD part is fully provided with Platform Bulder in source code. For PDD there is template which should be customized for specific hardware platform. Bsquare adapted this template to OMAP35xx EVM which differs from BeagleBoard in USB HS Host architecture (BeagleBoard System Reference Manual Revision C3.0 8.10):
1. BeagleBoard (EBVBeagle rev C2) uses PHY transceiver with ULPI (UTMI+ Low Pin Interface) - USB3326C.
2. External control of VBUS by TWL4030 aka Triton 2 controller using TPS2061 power-distribution switch.
- PHY Transciever -
ULPI is implemented on hardware level. EHCI controller of OMAP35xx provides register (INSNREG05_ULPI) to configure and get status of ULPI. In case of EBVBeagle rev.C2 ULPI works fine without any configuration except for control of RESETB pin of transciever. EHCI driver in BSP has 2 stubs which bring PHY to reset and enable state. To get it working appropriate GPIO (GPIO_147) should be used in stubs. Also OMAP pins have to be configured to provide this GPIO. There are two places to configure (mux) pins: XLDR aka MLO or OAL. To have universal bootloader (MLO) I placed this code to OAL (oem_pinmux.c).
- VBUS Power Control -
By default TWL4030 is configured to enable LEDA which is used as nEN_USB_PWR signal for power-distribution switch. But LEDA is also used by backlight driver via tled driver. So the easiest way to power VBUS is to disable these drivers by setting BSP_NOBACKLIGHT and BSP_NOTLED variables. Smart solution is to provide power control via appropriate procedure in EHCI driver (PortPowerControl), which was added in BSP v.6.12

* DVI-D output
DVI-D works with variable success. Usually, when system has just booted up, picture on display is clear. Then randomly during user interaction (startup application, mouse pointer movement) picture disappears for a while and display shows black screen. I've performed tests on different displays (LG Flatron L204WT and Benq plasma TV [unknown model]). So I think it's a hardware/software problem of DVI-D framer (TFP410). I'm going to investigate this problem and in case of success I will report results. Please let me know if you are/aren't experincing such problem with DVI-D output on your BeagleBoard.

Pavel Belevsky

Dec 2, 2009 at 6:43 AM

Hi Pavel,

Thanks for sharing your experience with us.

Being I don't have a C2/C3 revision Beagle I havn't worked through USB host yet.  I just added GPIO spreadsheet in ODS and Excel format to the repository (ODS = Open Office Document).  Cells in Green are ones I changed and tested myself.

If you wouldn't mind taking a look at it and providing any feedback on my "Beagle Remarks" column for USB host mode.  That would be appreciated.

I experienced similar issue with the DVI output, although I've only tested on a first generation DVI monitor.  Odd thing is the same part is used on the EVM board, only variation is the GPIO used for the TFP410 /PD pin.  I expect you adjusted for this as well?



Dec 2, 2009 at 6:32 PM
Edited Dec 3, 2009 at 7:12 PM

Hi Joel,

Thanks a lot for advice. DVD-D output now works fine with both displays (LG and BenQ PlasmaTV). Before I'll comment your records about GPIO I'd like to complete my description of BSP adaptation

* USB HS Host
By default BSP settings are configured to use USBTLL module of OMAP, instead of ULPI. So to enable ULPI bypass you should set BSP_HSUSB2_12PIN variable. Also EHCI is disabled by default (set BSP_NOUSBEHCI=1). Comment out this line in BSP configuration batch file to enable it. In BSP v.6.12 EHCI driver is located at common platform code folder (PLATFORM\COMMON\SRC\SOC\OMAP...). So it is highly recommended to copy driver code to cloned BSP folder before modification.

* DVI-D output
DVI-D output implementation in BeagleBoard slightly differs from one in EVM. In EVM DVI-D framer is controlled by Triton 2, and in BeagleBoard - directly by OMAP using GPIO_170. Display should work as soon as possible to show boot pattern or logo. To do so GPIO pin should be correctly configured in XLDR/MLO as I did. Display mode is selected by BSP_DVI_xyz variables

* GPIO spreadsheet comments
1. ETK_D7,D8,D9 aren't used in USB HS host subsystem of BeagleBoard
3. LEDA/VIBRA.P of Triton 2 is used as nEN_USB_PWR
4. I've not implemented checking of overcurrent event (HOST_nOC). Sorry, no comments
5. Addition. UART2_TX/GPIO_147 resets/enables PHY transciever

Next week I'm going to "taste" more interesting features such as video decoding and OpenGL. Good luck



Dec 4, 2009 at 5:58 AM

Hi Pavel,

Thanks for the input.  This will save others some time that need USB host (non OTG) working.


Dec 10, 2009 at 7:49 PM
Edited Dec 10, 2009 at 8:12 PM

Hey, I've been working on getting the EVM bsp working with my beagleboard. The only problem I'm having thus far is getting the DVI to output correctly. S-Video works fine, but dvi causes monitors to stay blank. I'm certain this is due to the sync frequency being incorrect, but I'm having a bit of trouble fixing the issue. It seems that Pavel and joelw have fixed this. Would either of you mind filling me in on how? I'm newer to this stuff so please be descriptive if your are willing to help.


Dec 11, 2009 at 5:32 AM

Hi there,

You need to change the code so that the correct GPIO is used for the TFP410 /PD signal.  Check my GPIO spreadsheet, or the schematics.


Dec 11, 2009 at 10:16 PM

Hey joelw,
Thanks for responding. Based on the cad file for the BB and the file you have, it appears GPIO_170 is the gpio i'm looking for. So now I know what I need to change (I admit I actually got this far before), but I was having trouble finding the file where the code needs to be changed. A lot of the GPIO's appear to be referenced locations so it is quite confusing. Is there anyway you could give me a filename? I realize some people don't want you giving information that is too specific, and so if it is a problem posting that info here, my email is rkaplan27@gmail.com. Thank you for your time.

Dec 18, 2009 at 3:56 AM

Sorry for asking something very basic.  I assume these modifications are done to for example: C:\WINCE600\PLATFORM\TI_EVM_3530\SRC\BOOT\XLDR\platform.c (once you apply the right env vars).

The function in question is GpioSetup() around Line 85.


Would you be able to post the modified code lines used to enable GPIO 170 or what your modified GpioSetup() looks like for DVI related activities.


Thanks in advance.



Dec 18, 2009 at 4:35 AM

Inspecting the code and schematic, it would appear to be


// Bank 6 GPIO 160..max
    OUTREG32(&pGpio->DATAOUT, 0);
    OUTREG32(&pGpio->OE, ~(BIT26|BIT22|BIT20|BIT17));

where BIT20 maps to GPIO_170.  Does this match your change?

Dec 18, 2009 at 4:45 PM


Now I'm "struggling" with video processing on DSP. OpenGL ES driver works fine without extra efforts. Moreover this platform is the first one which really accelerates Silverlight applications. Usually "Carousel" example runs with 4 fps rate. On Beagle with enabled OpenGL ES hardware acceleration it runs with 27 fps rate! Coming back to video processing WMP plays MP4 and H264 video as expected, but USB HS host functionality comes unstable during playback/decoding that looks like switching off and on several times and finally USB stops working. It's strange because IVA and USB HS subsystems have no common modules and I've not found any relation to power management events.  Any ideas are welcome.
Small addition to description of BSP adaptation conserning GPIO setup:

* GPIO setup
Generally GPIO setup consists of following tasks:
1. Configuring/muxing pin, which isn't GPIO by default, to GPIO mode.
2. Configuring GPIO.
These steps can be fulfilled in bootloader (XLDR/EBOOT) and/or in OAL. So making changes in bootloader you should check that OAL code will not eliminate your work.
Pin multiplexing procedure and modes table are specified in "Pad Functional Multiplexing and Configuration" section of "OMAP35x Applications Processor TRM". Examples of pin mux are in BSP source code and can be easily adapted to any GPIO. Then if GPIO is used for output it should be enabled (GPIO_OE register) and output value should be set (GPIO_DATAOUT register). For details refer to "24.5.4 Data Input (Capture)/Output (Drive)" section of "OMAP35x Applications Processor TRM".
Example: GPIO_170. Search in documentation ("OMAP35x Applications Processor TRM") results that "CONTROL_PADCONF_I2C3_SDA[31:16]" should be configured to "Mode 4" with disabled input because GPIO will be used as output. According documentation GPIO_170 belongs to GPIO6 module which starts from GPIO_160. So 10th bit should be used in GPIO_DATAOUT and GPIO_OE registers

Dec 23, 2009 at 3:53 AM

So i am still attempting to get DVI outputting properly. I've followed pavelb's directions (it seems platform.c was where these changes need to be applied), but nothing has changed. I was wondering if the lcd_support.c file needs to be modified as well, for it appears to be enabling DVI for the EVM? As I am a student attempting to get this to work for a project, anyone care to be generous and share a little more insight on this issue?


Dec 23, 2009 at 6:44 AM

Hi Rkaplan,
First of all you should diagnose your board: http://code.google.com/p/beagleboard/wiki/BeagleBoardDiagnostics

Pavel Belevsky

Dec 23, 2009 at 7:47 AM

Thanks for the response pavel. I have tested the bb with the gumstix bsp demo, the bsp demo's from bsquare (clearly those don't enable stable dvi), and the diagnostics. The gumstix demo and the diagnostics tools showed the board does output dvi successfully, so it must be something i'm doing wrong with the bsp modificaitons. As I said, I followed you directions and modified platform.c in the xldr folder. Changes made are as follows:




OUTREG32(&pGpio->OE, ~(BIT26|BIT22|BIT17|BIT10));

As well, in the OALLIB, in the file oem_pinmux.c, the following change was made:


This did not seem to allow stable DVI output. I was considering that lcd_support.c needed to be modified as well, as it seems to enable dvi for the evm, but i figured that this shouldn't be needed after the other changes. I appreciate your response again, and look forward to your information on resolving my DVI issues.


Dec 23, 2009 at 8:12 AM
Edited Dec 23, 2009 at 8:13 AM

You've configured GPIO_185 instead of GPIO_170, because "pConfig->CONTROL_PADCONF_I2C3_SDA" refers to "CONTROL_PADCONF_I2C3_SDA[15:0]" instead of "CONTROL_PADCONF_I2C3_SDA[31:16]".

Dec 23, 2009 at 8:31 AM
Edited Dec 23, 2009 at 6:12 PM

Thank you so much, complete success now. If there's anything I can help you with testing/debugging let me know and I'll be more then happy to help. My next task is to figure out how tweak the pixel clock to the hdmi (this applys mainly to tv's) standard 74.25 mhz .

Feb 9, 2010 at 11:34 AM


Some people don't like you posting that extra amount of code here (i got notified myself on a few occasions and took it down). The fact is that code is licensed and out of respect for the coders and the group (i suspect the wrong person seeing that may try to shut the group down, who knows though) you may wanna remove that... In any case, I do feel for you because its hard to get a direct answer sometimes, but just try and be a bit more subtle / post less code at the very least. Well, now that i sufficiently feel like a hypocrite, I guess i should redeem myself by helping you.

To the point, No. Pretend you didn't do anything, and go back to my first post made on 12/23/09, read it, then consider Pavels followup post as I have repeated / slightly trimmed it down below:

1. " you've configured GPIO_185 instead of GPIO_170 "

2.  "CONTROL_PADCONF_I2C3_SDA[15:0]" instead of "CONTROL_PADCONF_I2C3_SDA[31:16] "

Now at this point you should realize there's only one thing wrong with the code in my post...

3. Once you realize what that problem is, the next step for you is download the Omap35x TRM (http://www.ti.com/litv/pdf/spruf98d).

4a. Next, put aside 10 minutes or so and read the pdf (jk)

4b. Search the manual for some of the terms stated in 1 and 2.

Tips:   i. If your still unsure of what to do, consider the fact that each pin has multiple modes.

          ii. If your still unsure of what to do, look back in those files you mentioned then reconsider Tip i.

          iii. If your still unsure....reconsider 4a. for a couple days instead of 10 minutes  : )

Let me know how it goes, as it will help others.

May 8, 2010 at 6:19 PM

Hi guys I got a beagle board  C4 in my hands recently and I am trying to boot it with windows CE.

The problem is that I have no previous experience in building and booting  WIn CE using  VS 2005.

I downloaded the bspsource_omapwince_06_13_00 and followed carefully joelw's instructions and maged to 

build both retail and debug build. The NK.bin images are around 1,3 MB (retail ) and 5,5 MB (debug). Aren't they

a little small?

Afterward I tried to boot from SD (cause I had problem installing the RNDIS driver). The first level of bootstrap (EBOOT)

seems successful. I the DVI-output I see the four colors and in the serial output I have the menu to choose booting method

and disable KITL. After I get :

Init HW: controller RST
BOOTLOADER: PartitionTable[0] Flag:0x80, Type:0xb, Start:0x3F, Size:0xC8034
BOOTLOADER: PartitionTable[1] Flag:0x0, Type:0x83, Start:0xC8073, Size:0x2ED1FF
BOOTLOADER: PartitionTable[2] Flag:0x0, Type:0x0, Start:0x0, Size:0x0
BOOTLOADER: PartitionTable[3] Flag:0x0, Type:0x0, Start:0x0, Size:0x0


Download file information:
[0]: Address=0x84001000  Length=0x00534d54  Save=0x80001000
Download file type: 1
 <> Record [ 0 ] dwRecAddr = 0x84001000, dwRecLen = 0x4
 <> Record [ 1 ] dwRecAddr = 0x84001040, dwRecLen = 0x8
 <> Record [ 2 ] dwRecAddr = 0x84001048, dwRecLen = 0x4
 <> Record [ 3 ] dwRecAddr = 0x84002000, dwRecLen = 0x37000
 <> Record [ 4 ] dwRecAddr = 0x8403A000, dwRecLen = 0x22FFC
 <> Record [ 5 ] dwRecAddr = 0x8405E000, dwRecLen = 0xA0CD4
 <> Record [ 6 ] dwRecAddr = 0x840FECD4, dwRecLen = 0x332C
 <> Record [ 7 ] dwRecAddr = 0x84102000, dwRecLen = 0xA069C
 <> Record [ 8 ] dwRecAddr = 0x841A269C, dwRecLen = 0xA80
 <> Record [ 9 ] dwRecAddr = 0x841A4000, dwRecLen = 0x1080
 <> Record [ 10 ] dwRecAddr = 0x841A6000, dwRecLen = 0x9E43C
 <> Record [ 11 ] dwRecAddr = 0x8424443C, dwRecLen = 0x9E8
 <> Record [ 12 ] dwRecAddr = 0x84245000, dwRecLen = 0x11C
 <> Record [ 13 ] dwRecAddr = 0x84246000, dwRecLen = 0x1305C
 <> Record [ 14 ] dwRecAddr = 0x8425A000, dwRecLen = 0x1305C
 <> Record [ 15 ] dwRecAddr = 0x8426E000, dwRecLen = 0x7E53C
 <> Record [ 16 ] dwRecAddr = 0x842EC53C, dwRecLen = 0xB68
 <> Record [ 17 ] dwRecAddr = 0x842EE000, dwRecLen = 0x4090
 <> Record [ 18 ] dwRecAddr = 0x842F3000, dwRecLen = 0x2A0C8
 <> Record [ 19 ] dwRecAddr = 0x8431E000, dwRecLen = 0x3BFFC
 <> Record [ 20 ] dwRecAddr = 0x8435A000, dwRecLen = 0x5FD0
 <> Record [ 21 ] dwRecAddr = 0x84360000, dwRecLen = 0x2F324
 <> Record [ 22 ] dwRecAddr = 0x84390000, dwRecLen = 0x17324
 <> Record [ 23 ] dwRecAddr = 0x843A8000, dwRecLen = 0xA030
 <> Record [ 24 ] dwRecAddr = 0x843B3000, dwRecLen = 0x1B000
 <> Record [ 25 ] dwRecAddr = 0x843CE000, dwRecLen = 0x3EFFC
 <> Record [ 26 ] dwRecAddr = 0x8440D000, dwRecLen = 0x221F8
 <> Record [ 27 ] dwRecAddr = 0x84430000, dwRecLen = 0x34FF8
 <> Record [ 28 ] dwRecAddr = 0x84465000, dwRecLen = 0x153E4
 <> Record [ 29 ] dwRecAddr = 0x8447B000, dwRecLen = 0x27F8
 <> Record [ 30 ] dwRecAddr = 0x8447D7F8, dwRecLen = 0x54
 <> Record [ 31 ] dwRecAddr = 0x8447D84C, dwRecLen = 0x670
 <> Record [ 32 ] dwRecAddr = 0x8447E000, dwRecLen = 0x2FAC
 <> Record [ 33 ] dwRecAddr = 0x84481000, dwRecLen = 0x20F80
 <> Record [ 34 ] dwRecAddr = 0x844A2000, dwRecLen = 0x4FF0
 <> Record [ 35 ] dwRecAddr = 0x844A7000, dwRecLen = 0xF0
 <> Record [ 36 ] dwRecAddr = 0x844A8000, dwRecLen = 0x20B8
 <> Record [ 37 ] dwRecAddr = 0x844AB000, dwRecLen = 0x10A8
 <> Record [ 38 ] dwRecAddr = 0x844AD000, dwRecLen = 0xC0EC
 <> Record [ 39 ] dwRecAddr = 0x844BA000, dwRecLen = 0x2C
 <> Record [ 40 ] dwRecAddr = 0x844BB000, dwRecLen = 0xC0EC
 <> Record [ 41 ] dwRecAddr = 0x844C8000, dwRecLen = 0x2C
 <> Record [ 42 ] dwRecAddr = 0x844C9000, dwRecLen = 0x1030
 <> Record [ 43 ] dwRecAddr = 0x844CB000, dwRecLen = 0x14FF0
 <> Record [ 44 ] dwRecAddr = 0x844E0000, dwRecLen = 0x7EBC
 <> Record [ 45 ] dwRecAddr = 0x844E8000, dwRecLen = 0x5FF0
 <> Record [ 46 ] dwRecAddr = 0x844EE000, dwRecLen = 0x2FF0
 <> Record [ 47 ] dwRecAddr = 0x844F1000, dwRecLen = 0xEFF0
 <> Record [ 48 ] dwRecAddr = 0x84500000, dwRecLen = 0x212B8
 <> Record [ 49 ] dwRecAddr = 0x84522000, dwRecLen = 0x13D54
 <> Record [ 50 ] dwRecAddr = 0x0, dwRecLen = 0x8400F52C
ImageStart = 0x84001000, ImageLength = 0x534D54, LaunchAddr = 0x8400F52C
Computing checksum: image start = 0x80001000, len = 0x534D54
Checksum = 0x1EB32028 (0x534D54 bytes)

Completed file(s):
[0]: Address=0x84001000  Length=0x534D54  Name="" Target=RAM
ROMHDR at Address 84001044h
Launch Windows CE image by jumping to 0x8000f52c...

Windows CE Kernel for ARM (Thumb Enabled) Built on Sep 30 2007 at 22:35:41
ProcessorType=0c08  Revision=3
OEMAddressTable = 8400f5cc
CPU CP15 Control Register = 0xc5387f
CPU CP15 Auxiliary Control Register = 0xe3
--- High Performance Frequecy is 32768 khz---
Changed KITL zone mask to 0x00008001
WARN: OALKitlInit: KITL Disabled


But no DVI - output.

I have followed your instructions and using rkaplan27 code I changed the code for the CONTROL_PADCONF_HDQ_SIO pin

but the problem persists. Do I have to include any more environmental variables on the build? Could you suggest

another solution. I have successfully booted using Angstrom so I do not think that is a hardware problem.


Thank you in advance


May 30, 2010 at 10:42 PM

Hi. I'm just following instructions for enable USB Host. I have beagleBoard rev C3. Chip was changed to TPS65950. I changed oem_pinmux.c and platform.c for GPIO_147 but still no luck. USB doesn't get 5V.

Jun 2, 2010 at 9:10 PM

It's not an issue. TWL4030 and TPS65950 are software compatible

Jun 2, 2010 at 9:37 PM

Just changed BSP to 6.12.3 and USB host works now. In last BSP (6.14) system.c is almost empty - all code was removed from assert/deassert

Jun 3, 2010 at 9:46 PM

Very useful thread. Thank you. DVI is stable now. It can be solved looking only on beagleboard schematics - pin definition for GPIO_170.

My problem now is registry. Registry changes, like timezone are not saved after restart. Any advice? Thank you.

Jun 3, 2010 at 10:33 PM
PRJ_ENABLE_FSREGHIVE = 1 solved the problem
Oct 12, 2010 at 2:48 PM

hi everybody,

sorry for coming after the war, I have an issue concerning s-video on my beagle, and maybe someone can help me...

My system is correctly booting until then, and I can see it on DVI output.

After I have set environment variable BSP_TVOUT_PAL to 1, I obtain a black screen instead of nothing like before, Does anyone have an idea, what I could check? Has it anything to see with what was written above about this GPIO_170?

thank you for help


Oct 14, 2010 at 3:46 PM


is someone still viewing those posts?

I would enjoy if someone ocud help me with my previous question about S-Video.

Except this, it will maybe seem to you stupid question, but what damn is stubs??

Thank you