enabling the HS-USB host port

Dec 22, 2009 at 5:23 AM

hi all,

i am currently booting beagleboard with the TI-EVMBSP3530 and am able to achive the following:

- execute xldr/eboot

- using eboot and USB-RNDIS could download Nk.bin to target board

 - beagleboard boots up with display output to DVI-monitor

I fruther want to proceed by enabling the USB-Host port to be able to work with USB mouse and USB keboard.

Since i am using OTG port for KITL, so alternative is to enable the USB Host port. However even after adding the required components i could not succeed. I read in this discussions,PavelB had succeeded in working with USB.  Can anyone please tell me how to proceed for enabling this USB Host port in TI's BSP.

waiting for reply


Dec 22, 2009 at 7:35 AM

What modifications have you performed to get working USB HS?

Dec 23, 2009 at 4:49 AM

hi pavelb

for enabling USB Host port i have added the environment varaible BSP_HSUSB2_12PIN=1 and enabled ehci driver by REM BSP_NOUSBEHCI=1 in the batch file and hence able to build the ehcihcd driver dll which also gets loaded on the target. i have updated the xloader/eboot with the new image built. However when i try inserting the USB mouse or USB hub nothing seems to enumerate.

Am i missing on modifying some piece of code in the BSP. i am also not clear of what changes are required to change in the ehcihcd driver.

It will be great if u can help me with what modifications u have done to make usb host working.

thanks and regards



Dec 23, 2009 at 4:51 AM

Parsh12, Would you mind telling me the changes you made to get the DVI working?

Dec 23, 2009 at 6:31 AM


i have set the follwing environment varaibles: BSP_DVI_640W_480H=1, BSP_DVI_ENABLE=1, BSP_NOBACKLIGHT=1 and BSP_NOTOUCH=1 and did a clean build. then i updated the xloader and eboot with the new images built. this enables the dvi output as a 4 color pattern. after downloading the kernel image normal desktop will be booted up to display monitor.


Dec 23, 2009 at 6:34 AM

Hi, Parsh
First of all you should use powered USB 2.0 hub, because of:
1. BeagleBoard provides insufficient power
2. HS port works with HS devices only
To easy diagnostic I recommend to use optical mouse with visible emission
Next steps:
1. Configure GPIO_147, for example in XLDR (platform.c). See "GPIO Setup" section in "EBVBeagle rev.C2" thread.
2. Implement stubs (PHY_AssertReset, PHY_DeassertReset) in EHCI driver code to reset/enable PHY. See both "HS Host" sections in "EBVBeagle rev.C2" thread.
3. Disable backlight driver. See both "HS Host" sections in "EBVBeagle rev.C2" thread.

Pavel Belevsky

Dec 24, 2009 at 5:38 AM

hi pavel

i am currently using the usb2. hub and optical mouse.

i m unable to understand how to setup the GPIO_147, the bits calculation etc.

according to me this would be the change required, correct me if i m wrong. Also can u help me how to understand this.

OUTREG32(&pGpio->OE, ~(BIT26|BIT22|BIT17|BIT19));
As well, in the OALLIB, in the file oem_pinmux.c, the following change was made:
waiting for reply
Dec 24, 2009 at 7:04 AM

Main part of GPIO setup - pin mux has been done. Move forward to PHY stubs.

Dec 24, 2009 at 10:17 AM

Hi Pavel

i am sorry but i couldnot understand what u mean..do u mean that the above code snippet is correct and i can use the same. Now i need to implement for PHY_AssertReset, PHY_DeassertReset functions.

please reply for the same. i really appreciate ur guidance in this regard

Dec 25, 2009 at 7:23 AM


I'm not sure if you did it, but you need to modify platform.c in the xldr folder to get DVI working consistently (GPIO_170 needs be enabled as an output):


I also thought i'd mention that I've been attempting to get 720p support for hdmi working, as the pixel clock is 72 mhz instead of the standard 74.25 mhz. I know there is support in the bsp that fixes this using the dsi pll (do a search for hdmi or dssai), but I have yet to investigate this more then that. In any case, most DVI monitors will work with just the gpio change.

Dec 25, 2009 at 11:34 AM
Edited Dec 25, 2009 at 12:20 PM

Parsh, your code looks OK. As you've already disabled backlight driver (BSP_NOBACKLIGHT=1), you should modify PHY stubs at last


Dec 29, 2009 at 10:10 AM

Hi Pavel

I have made the changes as per the code snippet i attached in the previous mail. Also i am using the USB 2.0 externally powered hub and an optical mouse. However with this change also the USB Host port doesnot enumerate the mouse or the hub. I also tried to externnaly power up the board using the dc source of 5v still no change.

Can u please let me know where am i missing. Am i correct in using the bank5 for GPIO 147 and it corresponds to BIT19 so the change would be

OUTREG32(&pGpio->OE, ~(BIT27|BIT26|BIT25|BIT24|BIT19)); 

Can u please update me with what changes u have done to make it working. Thanks for your assistance in this regard.




Dec 29, 2009 at 11:07 AM
Edited Dec 29, 2009 at 11:10 AM

Hi, Parsh

What BSP version do you use? In BSP v.6.12.03 and higher all code is in place and the only thing that you should do after pin mux [OUTREG16(&pConfig->CONTROL_PADCONF_UART2_RX, (INPUT_DISABLE | MUX_MODE_4));] is change GPIO number in PHY_ functions. I wonder if you leave #if 0 ... #endif directives uncommented


Dec 30, 2009 at 7:30 AM
Edited Dec 30, 2009 at 7:31 AM

Hi Pavel
I have again cross checked the changes made by me and as suggested by you in the previous mails. I am using Beagleboard C3 revision board and TI-EVM-3530 BSP(ver-6.12.03).
i have added the pin mux for GPIO147 under DEVICE_PINMUX_BEGIN(OMAP_DEVICE_USBHOST2, D0) in oem_pinmux.c file. Also the PHY_ functions have enabled code for GPIO 147. Is there any other code which needs to be commented.You have mentioned about ETK7,8,9 not required for USB-HS.
When i insert USB2.0 hub into USB-HS port and insert optical mouse, it gets the emission, however doesnot move the pointer on the desktop. Also any other USB device (like USB keyboard, USB card reader, pendrive etc ) donot get their leds blink. I am not sure how to find that the USB-HS port is actually working apart from these steps.

Can you please guide to any further changes required. Please help me with this problem.

Dec 30, 2009 at 10:14 AM
Edited Dec 30, 2009 at 10:38 AM

I saw your post, and since I would like this fixed as well, I have began sorting through the issue as well.....

I have edited this post, as pavelb has replied, and what I stated seems to be wrong, I'll let you know if mine ends up working.

Dec 30, 2009 at 10:20 AM

1. Check voltage on BeagleBoard USB HS connector
2. Check final registry setting (reginit.ini) - "Port2Mode" should be "dword:1"
3. Check that all required USB client drivers (USB mouse, keyboard and etc.) are included
4. Build debug image and watch messages concerning USB host and client drivers. During loading of EHCI driver you should see "PHY assert" and corresponding "PHY deassert" messages. Check enabled debug zones - they might be commented/disabled by default.


Dec 30, 2009 at 12:54 PM
Edited Dec 30, 2009 at 8:54 PM

My progress on this issue consists of the following.

In oem_pinmux.c:



In platform.c:


and at gpio bank 5

OUTREG32(&pGpio->DATAOUT, BIT25|BIT19);   
OUTREG32(&pGpio->OE, ~(BIT27|BIT26|BIT25|BIT24|BIT19));   



So I have modified system.c to reflect gpio_147 and commented out the #if 0's, but still no luck.


1. A very quick voltage test on the BB HS connector is showing 5v

2. regedit.ini does not have any reference to port2mode

     -Based on pavel's last post, i'd have to say that this is an issue, but I don't now why it is being caused. I should also note to parsh12 that I have had similar experiences to that of what you observed for different devices led emission. I believe this indicates that the power is on, but the the system is not set up properly (excuse my pun, but this appears to be a literal take on the phrase "the lights are on, but nobody's home")

Any help here pavel (or anyone else) would be appreciated.


FYI: My SD write protection issue was solved by modifying a registry key.

Dec 31, 2009 at 4:23 AM

Hi Rkaplan
I hope you checked reginit.ini file. Under the registry for USBEHCI u will find "Port2Mode"=dword:1 which corresponds to ULPI PHY. Also do u get the emission on for all ur usb devices beacuse i got it only for mouse.

Dec 31, 2009 at 4:57 AM

To make things simple, here a quick summary:

1. my reginit.ini does not have usbehci or port2mode in it

2. my keyboard get's emmision when both the power supply of the hub and the host port are connected. my mouse does not, but i believe this is due to the mouse waiting for the os to initialize it before emmiting. A voltmeter showed 5v on the host port when disconnected from the hub.

It is clear to me that the main problem is that I am missing the registry keys, but I have no idea why they aren't there. Any advice would be appreciated, and I want to thank you in advance for your time. What is your status?

Jan 1, 2010 at 1:29 PM

Your getting warmer.  Remember even if you do get the basics working you will not have very good throughput using the raw TI/Bsquare BSP.

The HS USB driver was never optimized like the OTG driver was by Bsquare/TI. Why I'll never know. Everybody had issues with both the OTG and HS USB (including TI) implementation. To some extent they have been solved ... at least the hardware aspects. The public drivers still lag. OTG host mode has a registry setting to operate at Full Speed max because of high speed issues. HS USB was removed from early BeagleBoard's because they could not get it working.

Remember USB 2.0 compliance does not necessarily mean "High speed". You can be 2.0 complient at full or even low speed.

As they say "your results may vary" and "don't operate machinery while using this implementation, consult your doctor"


Jan 3, 2010 at 12:46 AM

Thanks for the info and advice dvescovi. What you've described is pretty much what I've read in the discussions here and other places, and it would be interesting to see if the linux crowd has overcome the issue (that way we'd know if it's a hardware or software based issue). I believe pavel mentioned in one post that high speed video would cause the HS USB to have issues. New years made me take a 2 day break on working away at the issue I'm having, but it's back to work now, and I'll let you know if I solve my problem.

Jan 3, 2010 at 2:55 AM
Edited Jan 3, 2010 at 6:11 AM

So after looking over the registry, it seems that my issue may be caused by improper environment variables. Instead of using .bat files to rem and set env variables, I have been right clicking the osdesign in platform builder, going to properties, and then environment variables to set variables. As PBInitEnv.bat shows the env variables, I believe they are being passed properly. To confirm that the variables are being passed, I enabled to play player using its env variable, then, after doing a build->makeimg, I checked the resultant reginit.ini to see if the change was made. It was found that the variable had been passed. I suspect that this must mean I am missing a env variable, for the ehci sections of the registry would be included in reginit.ini if that was so. Could someone confirm that my finding make sense thus far. Thank you in advance.




I applied a modification to the platform.reg and platform.bib that now ensures both the ehcihcd.dll is included and the registry key is included with port2mode set to 1. Still no success after booting ce....any ideas?



Jan 6, 2010 at 8:29 PM
Edited Jan 6, 2010 at 8:30 PM

Thanks to all who helped me, I got it working finally. parsh I'll try and help you by stating my steps. Pavel did state the same directions, but I'll try to do what I can to clarify without posting code here:

1. modify the enviorment variables:

bsp_nobacklight=1 bsp_nousbttl2 = 1; bsp_hsusb2_12pin=1

2. modify xldr and oal pin mux for gpio_147 to have disabled input with gpio mode (as you did), and in xldr, in bank5 modifying gpio_147 to be output enabled and dataout (dataout may not be needed, but I did it anyway)

3. finally, edit the ehci source (found in the common folder) to reflect the gpio change, and ensure the comments are removed from "#If / #endif" statements


      a. after a successful, the ehci dll is included in the nk.bin

      b. after a successful, ensure reginit.ini included the registry key for ehci with the portmode2 set to a dword of 1 (ULPI Mode)

      c. after booting and in boot loader take a voltmeter to ensure the usb host port is reading 5v (i believe that's what I got)

If you having problems after all that, assuming the dll and registry key got included poperly:

    1. check that pin mux changes were done properly by referencing the omap35x TRM

    2. check that the 2 changes in the ehci source were done correctly

Oh ya, and thanx for that info dvescovi, I experienced some issues already. If I have time, I intend to find out what causes the issue.

Jan 6, 2010 at 9:54 PM
Edited Jan 7, 2010 at 9:01 PM

I have experienced that I can successfully get the internet through a usb hub/ethernet port combo I supplied drivers for that is plugged into the host port. Furthermore an sd card reader works. My problem is in using HID's. More specifically the keyboard and mouse aren't working as expected (the mouse can right click and mouse the pointer but very rarely left clicks, the keyboard's keys make audio sounds but don't all perform their specific function). Any ideas on if this is because of the ehci driver being bad, or something else?




Well, based on the fact that only the keyboard and mouse are experiencing issues, I am starting to think that the problem is due to the keyboard and mouse not being HS devices. If someone could confirm that this makes sense, I would appreciate it. I should also note that I have been messing with streaming video on a network, where the ethernet lan card is built into a hs hub on the hs host port. Audio is great, but video causes the host port to disconnect from the hub until the device is rebooted (tried unplugging and plugging it back in). This was consistently observed 4 times to confirm the issue.


Jan 10, 2010 at 9:48 AM

Congratulations, Rkaplan! FS/LS device shouldn't be a problem - it's a task of USB hub to convert FS/LS to HS. So try to change hub. Could you describe streaming video scenario in more detail? Who's store video and who's play?


Jan 10, 2010 at 12:22 PM

This is the very problem I described. Even though you get a High speed connection the throughput is really bad.

Video will show it. There are ways you can increase buffer sizes to get somewhat better operation but for the most part it pretty much sucks.

Video usually uses isochronous transfer mode which requires large buffers and DMA to meet real time requirements neather of which is implemented in the standard driver.



Jan 11, 2010 at 8:00 AM
Edited Jan 11, 2010 at 8:07 AM

Thanx for the info DV, I'll have to look into that, and I'll let you know if I have any promising results.

Pavel, thank you for the info as well. I should first give you an idea of the hub I am using: http://www.addlogix.com/subpage.asp?MM=MM4&m_id=68&ids=3 (Addlogix 3-port usb hub with ethernet), purchased from Bill Mar at specialcomp.com . I got the ethernet port drivers working with drivers I found on the web. My first tests were using the internet with IE, and that worked flawlessly. Next, I added support for windows file sharing to my image, and attempted to log into my pc, and this succeeded flawlessly as well. Continuing on, I decided to stream audio from my pc to media player, and that also worked flawlessly, and it ran without failure (i tested it for 30 minutes). Next, I decided to stream video from my pc, and after about 30 seconds of video playback, this caused an error in media player where the file being played could not be found. Essentially, this error was caused by the ethernet port loosing its connection, for the host port disconnected, and it remained in such a state until the device was rebooted.

My other hub problem that I mentioned was in using a non HS USB keyboard and mouse. Since both the keyboard and mouse worked with the OTG port, I decided to bring out a USB 2.0 logitech wireless mouse to test if the issue would still exist, and I have found that it works flawlessly with the USB Host port. I intend to look into getting a hub that will support both FS and LS devices.

As I have other needs for my device, I have also tested a bluetooth usb adapter and a usb webcam from MS on the hub connected HS Host port.

I enabled the universal bluetooth catalog item in platform builder, and found the bluetooth adapter was enabled in the OS and successfully paired with a set of bluetooth headphones I have that are made by sony. I did not test audio with the headphones, as I was only attempting to verify the bluetooth adapter worked.

I got drivers that successfully allowed the webcam to connect with the system, and I also found a simple webcam demo to go with the drivers. The webcam demo didn't work due to a directshow dependency I have yet to add, but I did notice that the demo gave a directshow dependency error when the webcam was connected, and when the webcam was disconnected, the demo gave an error communicating with the webcam's driver. These results are promising, but I will have to either get the directshow filter or modify the demo to determine if the webcam is working appropriately with both the driver and the HS usb host port. Currently I am most concerned with the HS USB host port working with the webcam's video output and not disconnecting.

One more thing I thought I should post is that all of my work was tested with the 061203 bsp, and I have migrated to the 061204 bsp (I just wanted to see if it worked and if any significant changes were made), and everything is working the same.

DV and Pavel, I appreciate your time, and please let me know your thoughts.

Jan 11, 2010 at 1:37 PM

I also got the web cam working a while back with a Logitech 9000 USB web cam.  I posted a youtube video about it awhile back.

If you look close you can see the image "jump" which are symptoms of poor buffering.

Also, there were no major changes from 061203 to 061204 that had to do with USB. Unfortunately, some of the changes they made of late actually made USB operation worse.

04 did add the directshow filters which do help with playback ... will have to wait for encoder improvements.

Jan 11, 2010 at 1:53 PM

Interesting, thanx for the info. I currently am working through getting a sample going for a MS Lifecam Cinema HD. The drivers definitely talk to the camera, but the demo code needs work to actually get an image out of the thing. Currently I am experiencing a nice little issue where I plug the camera into the HS USB, then start up the demo code, and attempt a still image, and I get an error (I found out it's an error in the code, not a problem with a filter dependency). Upon closing the demo, the light on the usb camera goes on. Better yet, opening up the app again causes the light to go off, and not go on again until the usb camera is unplugged, plugged back in, and I repeat the whole thing. Hopefully I can learn how to fix the demo program without taking too much time. I'll make a post if I have any success.

Jan 11, 2010 at 2:17 PM

I had a Lifecam too. Did not seem to work that good, I had lots of issues but I had an older model.

Logitech seem to do much better for me.

Jan 11, 2010 at 2:36 PM

I usually am a Logitech man in general (most of my keyboard, mice, and my harmony 880), but the 720p Lifecam Cinema has had good reviews, and seemed to be a good form fit for my needs. I am actually going to mainly be using it for still images, if I can get it working, otherwise it's going to be returned for a logitech (they do have the 720p models as well anyway). I have a feeling I may just swap it out today for a Logitech cam, for I suspect the issue I described before occurs when my demo app initializes the driver and the cam. Furthermore, at this point, my project needs to have more time dedicated towards software/UI design, and messing with hardware that may or may not work without a lot of developement is seemingly a poor use of my time.


Jan 13, 2010 at 11:36 AM

Well, based on a bunch of googling and the advice of DV, I swapped out the ms webcam for a logitech pro9000 (on sale this week it was an even trade for the lifecam cinema, and the logitech has better features). Furthermore, following the advice of Pavel and the changelog for the bsp ( :>) I noticed it was stated there after your comment), I purchased an inexpensive powered USB HS hub with LS device support. (Having quality computer stores with big selections, great sales, and easy return policies within walking distance of my current residents has really been helping my ce/beagle DEVing)

Before stating my experiences, I should first note that my tests with the new HS cam and clearly the HS hub with LS device support have been done using the HS USB port on the BB. Thanx yet again for the heads up Pavel, as the LS compatible HS hub was just what I needed, and I have not had any issues (beyond the streaming issue mentioned by DV and myself, but that's expected). The new webcam "appears" to be working with both the driver and usb hub I obtained. Yet again, thanks for good advise DV!! Anway, I stated "appears", for my webcam test demo is still under development and it isn't very stable yet.

Using a MS UVC tool I dug up from an archive on the net, I was able to obtain the webcam's specific UVC properties. I have confirmed that the demo can successfully query and modify most of the webcam's settings. As well, all of the webcam's supported streaming video formats, resolutions, and frame rates could be detected, and the same was found for still formats. Testing showed that initiating MJPEG streaming @ 15 fps with resolutions up to 800x600 would cause the camera's orange LED ring to turn on, and this signified active streaming. It was found that when left streaming, the activity LED would turn off after several seconds. Furthermore, it was found that repeating streaming tests with constant resolutions, frame rates, and settings would results in similar symptoms from the activity LED, but the illumination time would vary.

It was observed that increasing resolutions and decreasing frame rates proved to produce similar results to those of the lower resolutions at higher framerates, and repeated tests indicated that that the activity LED's average illumination time before failure would decrease as resolutions were increased. It was found that the highest resolution that would cause the activity LED to illuminate was 1280x720 @ 5 fps, but while the LED was on I noticed that the system was experiencing mild lagging. Furthermore, repeated tests of 1280x720 @ 5 fpswere observed to cause progressively increased lagging until the system would virtually stop responding, only showing mouse movements and making keyboard clicking sounds. Unplugging the web cam would result in the system returning to a functional state, and plugging the camera back in and restarting the demo program resulted in the camera responding again. I noticed that higher resolutions previously available for streaming would not work after the camera was removed.

The last demo test captured still images to be saved to the system's root directory (or where ever specified), but the stream and still image needed to have matching resolutions. While the webcam streaming worked as previously discussed, the still image capturing results varied unpredictably. Sometimes the still image request would give an error, and sometimes it would have a successful capture. A few times, it was observed that the camera would not respond until being unplugged, and it appeared that the cause was a timing conflict in starting/stoping streaming, and requesting an image capture. I successfully was able to obtain a JPEG image for each streaming resolution, but I noticed higher resolutions were more difficult and caused the system to lag out.


Currently I believe there are three issues that are causeing problems for my webcam / system:
 1. As I stated before, my demo is unrefined, and it is possible that the program and sometimes the driver are improperly being removed from the ram when they are closed/no longer needed. I believe this would produce system lags, crashes, and communication issues similar to what I have seen.

 2. The amount and allocation method for the ram is an issue for the webcam and other parts of my system. For my current platform, I have been using a BB C3 board with only around  40mb of ram to share with program and storage data after nk is booted off of an sd card. While most of my tested video and opengl demos succeeded in working with this configuration, there is no good reason that I should not have the entire 256mb of ram allocated for my system to use.  Using the tool for allowcating ram in control pane->system, I was able to confirm that the current ram allocation is not sufficient for most webcam's use, and that the ram was get pegged when streaming (especially higher resolutions). Furthermore, I found that both the driver and demo did not always clear out of the ram when the demo was exited, and I was only able to determine that the driver would drop and free up some ram when I unplugged the camera.

    -Following my findings, I decided to attempt to fix the ram issue in my platform, and I found that config.bib in the bsp's files directory is responsible to setting up the ram, and better yet, bsquare added a variable for systems with the 256 mb of ram BSP_SDRAM_BANK1_ENABLE. That was what I thought. I added the environment variable and did a clean build, (I should also note that BSP_DSPLINK was enabled previously), I attempted to boot my device from the sd card using my standard method of using MLO, EBoot.nb0, and NK.bin, but after downloading NK.bin into the IMGRAM, the boot fails to continue past the jump into NK.bin. To ensure the issue was due to adding the variable BSP_SDRAM_BANK1_ENABLE I rebuilt the image without it, and the image booted without a problem. Investigating the issue in config.bib revealed that the BSP_SDRAM_BANK1_ENABLE variable changed a few thinks about the ram allocations. To get an idea of what was happening, I quick referenced the following site:  http://msdn.microsoft.com/en-us/library/ms836792.aspx .

~Originally, I was allocating 128 mb in the following order:


RAM->RAM (40)



~Originally, I was allocating 128 mb in the following order:

NK->RAMIMG (72 mb)



RAM->RAM (128 mb)

In my successfully booting build, NK and RAM are contiguous, and this mean AUTOSIZE is set to ON. On the other hand, on my modified build, config.bib's comments indicate, adding BSP_SDRAM_BANK1_ENABLE as well cause AUTOSIZE to be off. Currently this is all I know, and I would really appreciate some good advice on how to fix the RAM issue/the Jump issue. Anyone know if theres anything else that needs to be modified in the bsp?

   3. The HS usb host may be dropping webcam packets, and causing problem with the cam..


Jan 13, 2010 at 12:06 PM

It looks like your are seeing most of the same things I discovered awhile back. I eluded to the buffering problem in a previous post.

I have a custom BSP for the BeagleBoard and Gumstix that has been highly modified. I reworked the config.bib and memory layout to make full use of the 256M Ram and Flash along with many, many other changes. The TI/Bsquare BSP memory implementation has been hacked as the 256M ram was an afterthought that came in as the newer, higher density chips came on the market. 

There is one registry change that will help somewhat with buffering but untill they add DMA and Isochronous transfer mode support your throughput will be limited.



Jan 14, 2010 at 5:35 AM

Thanks for the reply DV. Under the 3530 BSP device drivers section of the catalog, there is a DMA item. I admit I have not looked into this much, but would this help at all? Either way, I intend to see what I can do to to at least make the 256 mb available as you did. Should adding that enviornment variable be all I need to do, or did my system not boot because there needs to be other modifications? Thanks again for your time.

May 4, 2010 at 10:09 AM
rkaplan27 wrote:

Thanks to all who helped me, I got it working finally. parsh I'll try and help you by stating my steps. Pavel did state the same directions, but I'll try to do what I can to clarify without posting code here:


Thanks for the help. But I'm still not able to get the USB host to work. I did step 1 (easy), step 2 (I think I did it right) and 3 (I have no idea if it is correct).

As you can see I'm pretty unexperienced and therefore glad for every help I can get. It is really important for me to have ActiveSync and keyboard and mouse on the device.

Is there anyone who can help me? I understand that you are not allowed to post code here, but maybe you can send me a PM or something like that.

Thanks a lot,


Oct 21, 2010 at 9:11 AM

Hi all,

I very need your help, still about the USB host port, that is not working for me despite all your good advices.

What I cannot understand rigth now is the modification of the system.c file, or the ehci driver. Concerning the latter, I effectively found a folder named EHCI, and into it, some 10 files.c. But I really dont see what to modify.

I have to precise that I work on the last BSP version 06_15_00.

PLease help me...

thank you,


Oct 21, 2010 at 9:57 AM


could you please precise what you mean by remove the comments, I did not find any files with those comments. Could you be a little more precise pliiiiz, it is very frustrating.

Thank you


Oct 21, 2010 at 9:29 PM
Edited Oct 21, 2010 at 10:04 PM

What is your background, because this stuff does require embedded knowledge.


Oct 21, 2010 at 9:59 PM
Edited Oct 21, 2010 at 10:41 PM
I am learning the whole thing.
Originally, I am electronics engineer.
the thing is that how you presented the thing in the discussion, it seems to be only few changes to do, and I can't get to them, because you don't want to show code publicly (thing I can understand).
So, if you only could tell me what to change and where, it would be great.
Because it is so frustrating to see my OS is here but that I have no access to it...
Thank you
Oct 21, 2010 at 10:05 PM
Edited Oct 21, 2010 at 10:07 PM

    Go to the forum to respond to this and edit your last post, for it wasn't as private as you think. To answer you specific question, I suspect that the comments aren't there in your version, for there were EHCI changes between 061204 and  061500. I personally have not had the time to DEV with 061500, but other versions since 061204 have generally kept the files that others and I mentioned needed to be modified the same, and the specific modifications and environment variables have been changed. I can tell you right now that the only good way to do this stuff is to study it and/or learn it yourself. People here were excellent in assisting me with learning and pointing me in the right direction, but I had to learn a lot to understand where they were pointing me or what they were saying. Furthermore, I recommend you look in the general areas I mentioned for files associated with your issue and see what they are doing. As well, search relevant files or folders for keywords to speed up the process. 


Jan 16, 2012 at 12:53 PM

Hi rkaplan27,

you had mentioned in one of the above post:      FYI: My SD write protection issue was solved by modifying a registry key.

could you please mention how SD write protection can be disabled?


Jan 18, 2012 at 12:59 AM

Tell me what BSP your using and I'll give you my best advise.

Jan 24, 2012 at 9:46 AM

I wanted to save some files in SDcard in WEC7. But it was giving error that 'disk is write protected '.

Then I found that there is an option in the registry entry for SDHC using which I can disable SD card write protection. Now, I am able to copy the files to SD card..