USB RNDIS KITL + NK from NAND

Jan 18, 2010 at 8:09 AM

Hi all
Currently i am able to boot the kernel image from NAND by disabling KITL in the Eboot menu.However i have a doubt as to can i boot the kernel with debug device as USB RNDIS (as KITL transport) and KITL enabled.
Because when i try to boot kernel by enabling KITL it hangs after intitialising the RNDIS.However when i boot the image from RAM by downloading image through Platform Builder it boots nicely and KITL also works.
please reply if anyone has worked with USB RNDIS as KITL while booting from NAND.
regards
Parsh

Jan 19, 2010 at 5:10 AM

Hi Parsh,

You might try changing the default KITL transport in:

%_WINCEROOT%\PLATFORM\TI_EVM_3530\SRC\KITL\KITLEXE\oemkitl.c

In OEMKitlStartup() it will attempt to query OALArgs.  In case of NAND boot, I would expect pArgs to return NULL, and init LAN9115 KITL transport.  Try changing this to be USB RNDIS instead.

 

Joel

Jan 20, 2010 at 6:21 AM

hi Joel
thanks for replying. I tried to change args.devLoc.LogicalLoc to OMAP_USBHS_REGS_PA in OEMKitlStartup,however it doesnot invoke USB RNDIS KITL. It fails to intiliase the KITL.Also OALArgsQuery doesnot return NULL.
Is there anything i m doing wrong, as i m new to this. can you please give more detailed explanation of how to do this.
thanks in advance.
parsh

Jan 20, 2010 at 7:31 AM

Hi all
i thought i would give more information of how i want to use USB RNDIS KITL.When we use ebootnand to boot from mmc card and then use nk from nand, in this case it waits for connecting to desktop through usb-rndis kitl. this way when we attach target with Platform builder the image boots and kitl also wokrs fine.
any idea what chnage is required for the same, if ebootnand is in nand.
regards
parsh

Jan 21, 2010 at 4:37 AM
Edited Jan 21, 2010 at 4:38 AM

I misread your first post. When executing ebootnand and booting nk.bin from NAND, which output do you see?

1. "INFO: Boot configuration found"

2. "WARN: Boot config wasn't found, using defaults"

I expect you are seeing "WARN..."

Look at %_WINCEROOT%\PLATFORM\TI_EVM_3530\SRC\BOOT\EBOOT\main.c

The boot config default logic will attempt to read switch settings (starts around line 470) that don't exist on the BeagleBoard. You need to remove the code that attempts to read and parse switch settings, and select your desired default.

 

Joel

Jan 21, 2010 at 4:56 AM

And to be clear, when running ebootnand - if you do see "WARN: Boot config wasn't found, using defaults".  This means you haven't stored the eboot boot config when running ebootnand.

Jan 22, 2010 at 7:31 AM

Hi Joel
You are right, when i boot the nk.bin for the first time from NAND and have not saved the boot config settings in ebootnand it displays "warn: Boot config wasn't found...." message from main.c file. I have tried changing the default as:
g_bootCfg.bootDevLoc.LogicalLoc = BSP_NAND_REGS_PA + 0x20;
g_bootCfg.kitlDevLoc.LogicalLoc = OMAP_USBHS_REGS_PA;
However still while booting the nk.bin from flash the USB RNDIS KITL doesnot start and stops after displaying the following message:
..................
HostMiniInit:: !!
Rndis:: initialization: with addr=480AB000
Rndis:: Address static map to addr=B10AB000
Rndis:: initialization!
Please suggest what else can i try to make USB RNDIS KITL work while executing image from NAND.
regards
Parsh

Jan 23, 2010 at 5:50 PM

Hi Parsh,

I repro'd this and genereated item number in issue tracker.  It's item# 16067.

Initial load from PB will always work, the subsequent reboot will never connect.

 

Thanks,

Joel

Jan 28, 2010 at 9:56 AM

Hi Joel
Have you found any solution to the same as of now.
regards
Parsh

Feb 1, 2010 at 10:23 AM

Hi Joel
I wanted to give some more inputs for the same.
when i tried to debug the issue i found funtiona calls from PddInit to UfnInit for Usbfn. However the UfnInit function dies in call to StartUSBClock. i also checked the values from the TRM for setting up the OTG clocks . Any inputs as to what should be the issue/change in enabling the clocks for OTG.
please suggest. regards Parsh